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1. Overview 
The DMC’s imaging systems generate a variety of file formats.  The Fluoview-1000 
confocal (.OIB, .OIF) and the Marianas (.SLD) generate proprietary formats that are not 
widely supported.  The Spot software on the Nikon Diaphot uses widely supported 
formats such as TIFF and JPEG. The Huygens deconvolution software can generate 
multiple formats including TIFF, OME-TIFF, ICS, AVI and HD5F.  Fiji can generate 
TIFF, OME-TIFF, ICS and several other formats for quantitative use and for qualitative 
use such as 24-bit RGB TIFF, JPEG, AVI.  Fiji can open all of these formats via the Bio-
Formats plugin.   
 
Details of file formats and updating Fiji software are given at the end of this document. 
 
As of September, 2016, Fiji has the ability to open all files generated in the DMC. There 
is no longer any reason to export copies of all images from the Marianas or the FV-1000 
confocal as RGB TIFF or JPEG just because you want to look at them in Photoshop or 
Powerpoint.  This only fills hard drives with duplicate images and complicates your file 
transfers.   Fiji is a Java-based, cross-platform application freely available.   
 
Best practices require that your original files should be saved to your archival system, in 
their original format, as primary data.  Copies are then created with the bit depth and 
resolution appropriate for the intended usage.   
 
This document will be periodically updated as new formats or software capabilites arise. 
 

System Software Format Fiji Slidebook Fluoview Huygens 
FV-1000 Fluoview .oib R R R/W --- 
  .oif R R R/W R 
Marianas Slidebook .sld R R/W ---- ---- 
Huygens SVI multiple R/W R ---- R/W 
Spot Spot .TIFF R/W R/W ---- R/W 
R = Read, W = Write, R/W = Read and Write 
Table 1. File compatibility between the file types and software in the DMC. 
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2. Overview of Olympus file import 
Several applications can open the 2 Olympus files, OIF and OIB format. 
The OIF format requires that you select the ‘filename.oif’ file, not the 
‘filename.oif.files’ folder! 

2.1 Slidebook (Windows only) 

Opens the OIF and OIB formats with metadata for voxel size and emission wavelength. 
1. Open the Image menu; 
2. Choose Import/’FV1000…’; 
3. Select either the desired “oib” or “oif” file; 
4. Click on ‘Open’. 

2.2 Huygens  
Opens the OIF format but not the OIB. Files saved in the OIB format can be opened in 
Fluoview and resaved, or opened in Fiji and exported as 16-bit OME-TIFF stacks.  Use 
the Huygens Parameters Editor to double check the pixel size and z-step size, which are 
sometimes inaccurate. 

2.3 FIJI – (uses Bio-Formats plugin) 
Details on using Bio-Formats are in section 5. 

1. Select File>Open; 
2. Select the ‘.oif’ file or a ‘.oib’ file; 
3. The Bio-Formats plugin (bundled with FIJI) will open an options window; 
4. Select desired options, usually ‘Autoscale’, and either ‘Composite’ or ‘Custom’; 

2.4 FIJI – Import Channel Order Macro 
This macro was written for the DMC to open FV-1000 files with automated control over 
channel merger, type of projections and file conversion.  Settings can be applied to all .oif 
or .oib files in the same folder as a batch operation.  Macro installation is described 
section 6. 
 
Always install the latest version of this macro.  It will change periodically due to new 
methods and changes in either the Bio-Formats plugin or the Olympus file formats. 
 

1. Load the macro:  
a. click on ‘>>’ icon in the toolbar and select the macro from toolsets list 

2. Commands are visible from Plugins>Macro, or press a hotkey e.g. ‘1’; 
3. Press ‘4’ for a macro help window. 

OIF or OIB files can be opened and converted to RGB, 16-bit stacks, maximum intensity 
projection, etc. and saved to the source directory or to a selected destination directory  
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3. Overview of Slidebook file import 
Slidebook files can be opened by Fiji, provided your computer has been updated.  Full 
instructions are below, in section 7. 

1. Open Fiji; 
2. File>Open; 
3. Select the .sld file from directory; 
4. Press ‘Open’; 
5. Set Bio-Formats options 

a. View as Hyperstack, leave all else unselected 
6. Press ‘OK’; 
7. Select the desired images in the .sld file; 
8. Press ‘OK’; 

 
The Bio-Formats window displays contextual help in the right hand pane.  

4. Preserving Bit Depth and Metadata – why bother? 

4.1 Bit Depth. 

The recorded signal from each point in the specimen is assigned a value from 0 to 
maximum. The range may be 8-bits, (256 intensity levels), 12-bits (4096 intensity levels), 
14-bits (16,384 intensity levels) or 16-bits (65,536 intensities) depending on which 
detector is used. Files for intensity-based quantitation or deconvolution must be saved in 
16-bit format to save their full intensity range.  Exporting images as 8-bit grayscale or 24-
bit RGB color will scale the intensity values down to 256 intensity levels for each 
channel.   Other common formats such as JPEG, BMP, MOV, AVI, also scale intensities 
to 8-bits per channel and some may further damage intensities and resolution by applying 
lossy compression.  Movie formats are particularly damaging. 

4.2 Metadata 

Metadata allows your image to be described.  It contains the parameters of image 
acquisition, which may include pixel size, z-step, time intervals, laser intensities, 
exposure times, PMT settings, objective lens, etc.  Popular file formats such as TIFF and 
JPEG throw away most of the metadata, including pixel size and z-step.  The proprietary 
formats and some open domain formats created for research store a large amount of 
metadata. 

4.3  File formats for metadata 
The Slidebook and Fluoview native formats store all metadata.  The OME-XML TIFF 
option in Slidebook, Fiji/Bio-Formats and Huygens saves images as TIFF but with a 
block of XML code containing all of the original metadata.  That block may be inside the 
TIFF file, and ignored by XML-naïve software such as Photoshop, or saved as a separate 
file.  Images exported from Slidebook as 16-bit TIFF OME-XML place the XML 
metadata and each channel in a separate file.  When the Slidebook files are imported by 
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Bio-Formats or Huygens, selecting the first channel will usually open and merge all 
channels for that image and read in the metadata from the XML file. 
 
The common TIFF format will only store metadata if written with software hard coded to 
place such information in specific locations.  Unfortunately, there is no internal directory 
in TIFF files and metadata cannot be found unless the reading software is coded to look 
for it.  Other common formats such as JPEG, BMP, MOV, AVI also lose metadata. 

4.4 Fiji Metadata display. 
The amount of information displayed depends on the software that created the file.   

4.4.1 Fiji – Image> Properties window 

Displays the pixel size, z-step, spatial units and time intervals for the active image.  These 
can be edited and then applied to the active image, or set to apply to all images as they 
are opened.  This information may be written to the image file when saved by Fiji 

4.4.2 Fiji – Image> Show Info… 
This command displays a text window with metadata for the active window.  This may be 
quite limited and cryptic, depending on the software that wrote the file.  

4.4.3 Bio-Formats – ‘Display metadata ‘ opens a window with with 2 columns.  The 
metadata can be copied and pasted into a text file or spreadsheet.  

4.4.4 ‘Display OME-XML metadata’ organizes metadata in the manner of the OME 
metadata format. 

5. Bio-Formats Plugin Common Options 

 
The right hand pane of the Bio-Formats window provides contextual help as the cursor is 
held over each option in the left pane. 
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5.1 Metadata viewing 

5.1.1 Display metadata - Opens a window with with 2 columns.  The metadata can be 
copied and pasted into a text file or spreadsheet.  But, it may be truncated.   

5.1.2 Display OME-XML – Metadata is organized in the manner of the OME metadata 
format. 

5.2 Stack viewing 
Usually leave set to ‘Hyperstack’.  Another useful option is ‘Metadata only’. 

5.2.1 Split channels - Each channel opens as a separate stack. 
Useful with file formats erroneously open with channels interleaved, as though 
stepping through z-planes, instead of merged.  This can be corrected in Fiji with 
Image>Hyperstacks>Re-order Hyperstack… 

5.2.2 Split timepoints – each timepoint opens as a separate stack. 
Similarly, useful when 3D timelapse images open with dimensions mixed up. 

5.2.3 Autoscale – if checked, the histogram will be scaled to the first image in the series. 

5.2.4 Color mode - Images may be opened in different color schemes   
Composite - opens images as merged grayscale 

Set channel colors by Image>Color>Channels Tool/More, selecting each 
channel in turn for the active image 
Custom – Channels are assigned colors before opening, but the active image must 

be converted to Composite to view as merged color by Image>Color>Make Composite 

6. Fiji – Install Macro to Batch Process Fluoview-1000 Files 

6.1 Installing the Import Channel Order macro 
This macro was written by DMC staff to import Olympus files with automated control 
over channel merger, type of projections and performing batch operations.   Always copy 
the highest version number that does not say “Beta”. 
 
A list of commands with hot keys, e.g. [1], will appear in Plugins>Macros.   
Press ‘4’ to get a help window for this macro. 

6.1.1 ImageJ 
1. Open the Java package by right click, select ‘Show Package Contents’; 
2. Select the macro from the Software directory on the server; 
3. Copy to the ImageJ>Macros>toolset directory on your computer; 



Draft, subject to update as software evolves. 10/5/16 

Glen MacDonald, Digital Microscopy Center, University of Washington 

6.1.2 Fiji -Mac 
1. Open Fiji.app by right click, select ‘Show Package Contents’; 
2. Select the macro from the Software directory on the server; 
3. Copy to the ImageJ>Macros>toolset directory on your computer; 
4. Start Fiji; 
5. Click on the red ‘>>” button at right end of toolbar; 
6. Highlight the macro ‘Import channel order’; 

6.1.3 FIJI - Windows 
1. Open Fiji.app folder; 
2. Select the macro from the Software directory on the server; 
3. Copy to the ImageJ>Macros>toolset directory on your computer; 
4. Start Fiji; 
5. Click on the red ‘>>” button at right end of toolbar; 
6. Highlight the macro ‘Import channel order’; 

 

7. Fiji to open Slidebook files. 
It is much more convenient to open Slidebook files with Fiji rather than export images 
from Slidebook. You only need to open the image you want, when you need it and be 
assured its metadata will be intact. 
 
Fiji is a Java based, public domain software application that will run on MacOSX, 
Windows and various flavors of Linux.  The Bio-Formats plugin for Fiji can open ~170 
file formats and save to about 2 dozen formats, and is bundled with Fiji. You will need 
the following on your computer: 

1. Current version of Fiji; 
2. Java 8 (also known as version 1.8); 
3. The Slidebook file library.  

7.1 You don’t have Fiji installed? 
http://fiji.sc/#download 
 
This website will guide you through installation of Fiji. 
When done, you may need to change Fiji’s memory allocation to no more than 75% of 
your computer’s RAM.  Open Fiji, Edit>Options>Memory& Threads> enter the RAM.  
Don’t worry, it will only take what it needs when it has to open a large file.  You can also 
open files with Bio-Formats as “Virtual Stacks”, in which only the currently viewed 
image is actually held in RAM. 

7.2 Install or update to Java 8. 
Java installation instructions: 
https://java.com/en/download/help/mac_install.xml 
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Download the latest Java SE Development Kit for your platform 

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-
2133151.html 
Check the ‘Accept License Agreement’ then click on the link in the right hand column 
for your operating system.  Install by opening the downloaded file and following the 
instructions.  Note: the runtime version of Java is only for web browsers and will not 
support Fiji.   

7.3 Install the Slidebook library. 
Details for setting up Fiji from the Slidebook website: 
https://www.intelligent-imaging.com/techanswers.php - SLDinFiji 
 

8. Details of Olympus file formats 

8.1 Overview of Olympus file formats. 
Olympus has 2 proprietary formats for the FV-1000 confocal, .OIB and .OIF.  Both 
preserve bit-depth and contain extensive metadata.   

8.1.1 Olympus Image Binary format, .OIB 
Images and associated metadata are stored in a single file with a filename extension of 
“oib”.  This format has a size limit of 800 Mb on with Windows XP. 
 
Occasionally, Fluoview creates an OIB file that will not open by other software.  
Slidebook and Fiji will give an error message referring to a null file. Such files can be 
opened in Windows using the Olympus File Viewer, or Fluoview, but the software 
requires a longer than normal time.  The resulting file may be resaved.   

8.1.2 Olympus Image File, .OIF 
Each acquisition saves 2 objects: a text file of metadata “filename.oif” and a folder 
named “filename.oif.files”.  The actual images are saved as a series of TIFF images 
inside of the folder. One 16-bit image is saved for each channel in each image plane or 
timepoint.  Several other file types are also stored in this folder, as shown in section 
1.2.1.  This format allows large images to be saved to disk as they are acquired. 
 
Images for each X,Y location in multi-area stacks, such as timelapse, mosaic images and 
multi-point acquisitions are saved in subdirectories named as “Track000n”.   

8.1.3 File types within the OIF older 
Extension Contents Type 
.roi Region of interest for each image document 
.tiff 16-bit image TIFF image 
.pty Meta-data for each image document 
.lut Look-up Table for each channel document 
.bmp Thumbnail image representing the stack image 
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The tiff file for each image plane is named by appending the channel (“C00n) and z-
position (Z00n) to the filename.   

8.1.4 Naming Convention for OIF images. 
For example, a 3-channel z-series with 4 image planes named “myfile” saved in the OIF 
format creates a text file “myfile.oif” plus a folder “myfile.oif.files”.  The folder contains: 
 
Myfile_C001Z001.tif 
Myfile_C001Z002.tif 
Myfile_C001Z003.tif 
Myfile_C001Z004.tif 
Myfile_C002Z001.tif 
Myfile_C002Z002.tif 
Myfile_C002Z003.tif 
Myfile_C002Z004.tif 
Myfile_C003Z001.tif 
Myfile_C003Z002.tif 
Myfile_C003Z003.tif 
Myfile_C003Z004.tif 
 
Each tiff is accompanied by a pty file with metadata. “C001” represents the files from 
channel 1, “Z002” represents the files from the first z-plane, etc. 

8.1.5 Exporting in other formats 
Fluoview can save images as standard TIFFs, jpeg, bmp, etc., but all metadata, including 
voxel size is lost.  JPEG format risks degradation of intensity and spatial integrity due to 
compression. 
 


